Adobe InDesign

Материал из Википедии — свободной энциклопедии
Перейти к: навигация, поиск
Adobe InDesign
Adobe InDesign CS5 Icon.png
InDesign CS3 screenshot.png
Скриншот Adobe InDesign CS3 в среде Mac OS X
Тип

программа компьютерной вёрстки

Разработчик

Adobe Systems

Операционная система

Microsoft Windows, Mac OS

Последняя версия

СС (11.0.1) (16 июля 2015 год)

Лицензия

проприетарная

Сайт

adobe.com/products/indesign/

Commons-logo.svg Adobe InDesign на Викискладе

Adobe InDesign ([əˈdəubi indi’zain]) — программа компьютерной вёрстки (DTP), разработанная фирмой Adobe Systems.

InDesign является следующей после PageMaker усовершенствованной программой вёрстки. Adobe InDesign позволяет создавать документы для вывода их как на типографские машины промышленного уровня, так и на настольные принтеры, а также экспортировать созданные документы в различные форматы электронных изданий[1], в том числе PDF[2]. Версии InDesign CS6 и выше имели улучшенную интеграцию с компонентами популярного пакета Adobe Creative Suite. Инсталляция официальной версии программы не требовала особых навыков[3]. Начиная с версии CS3, интерфейс InDesign не подвергался кардинальным изменениям, так как основные функции программы не менялись.

Рабочее пространство[править | править вики-текст]

Рабочая область программы представляет собой конфигурацию палитр и меню[4], реализованных на основе графического интерфейса и имеет следующие составляющие:

Интерфейс Краткое описание функций рабочего пространства (конфигурации рабочей области)[5]
Панель приложения Масштаб, работа с линейками и направляющими, Adobe Bridge, режим просмотра
Панель инструментов Содержит инструменты для изменения и создания объектов на странице, эти инструменты имеют вид значков (иконок-кнопок). Выпадающее меню позволяет выбирать нужный инструмент. При наведении указателя на пиктограммы инструментов отображается всплывающая подсказка с клавиатурным сочетанием для их вызова.
Панель управления Эта панель даёт быстрый доступ к элементам управления и командам, она меняется в зависимости от выбранного инструмента.
Палитры (панели) Палитры (панели) предоставляют быстрый доступ к наиболее часто используемым функциям. Набор пристыкованных друг к другу палитр называют доком[6]. Общий список Палитр можно увидеть в меню Окно, причем, часть палитр скрыты в раскрывающихся списках.

Панель приложения[править | править вики-текст]

Панель приложения, по умолчанию, находится в верхней части рабочей области, в ней собраны, по мнению разработчиков программы, актуальные инструменты, некоторые из них указаны в таблице:

Панель приложения Меню Краткое описание функций элементов Панели приложения Adobe InDesign
Adobe Bridge Adobe Bridge позволяет удобнее управлять файлами и просматривать их.
Масштаб Размер в % InDesign позволяет просматривать макет в масштабе от 5 до 4000 %.
Выбор рабочего пространства и поиск Сбросить дополнительно и другие К примеру, начиная с версии «CS4», через эту панель возможно быстрое восстановление Рабочего пространства (Сбросить дополнительно).

Панель меню[править | править вики-текст]

Расположение Панели меню программы Adobe InDesign в системе Windows и Apple отличались друг от друга, но сами команды, как и функции программы, были одинаковы. Некоторые команды меню и подменю имели свою специфику, например, меню Файл:

Меню Файл Подменю Краткое описание функций меню Файл Панели меню
Новый Документ Важное диалоговое окно, в котором задаются параметры будущего документа, чаще всего Печать книги, однако, начиная с версии «CS5», появилась функции Web, в следующих версиях — Цифровая публикация.
Фолио Фолио содержит одну или несколько статей для цифровой публикации[7].
Открыть Открывает файлы формата программы InDesign. Файлы других форматов следует импортировать командой Поместить.
Сохранить как InDesign сохраняет файлы в специфическом формате indd, который не сможет открыть никакая другая программа вёрстки. Сохранить в другие форматы или форматы InDesign ранних версий можно через отдельную команду Экспорт меню Файл.
Поместить Поместить — это эквивалент команды Импорт из Photoshop и Illustrator. Этой командой можно импортировать в InDesign как графику, так и текст, к примеру файлы созданные в Word. При таком способе импорта форматирование исходных файлов остается в прежнем виде, тогда как импорт через буфер обмена уничтожает форматирование.
Экспорт Через команду Экспорт можно сохранить файлы сделанные в InDesign в другом формате или ранней версии программы. Для этого нужно при сохранении выбрать нужный Тип файла, в ранних версиях InDesign следует выбрать формат программы (.inx).

Панель инструментов[править | править вики-текст]

Панель инструментов является частью рабочего пространств программы InDesign. Маленькие черные треугольники на ней обозначают наличие скрытых инструментов в группах. В таблице отсортированы и описаны некоторые основные инструменты, включая скрытые:

Инструменты Краткое описание функций Панели инструментов InDesign
Выделение Инструмент Выделение, пользователи его называют «черной стрелкой», позволяет, в том числе, заполнять текстовые фреймы.
Текст Следует отметить, что без использования инструмента Фрейм текст разместить в документе невозможно, для создания текстового Фрейма, можно, выбрав инструмент Текст, нажать на левую кнопку мыши, либо преобразовать в текстовый пустой графический фрейм. Для литературного набора текста лучше всего пользоваться программой Word, впрочем, InDesign последних версий имеет все основные функции редактора текстов, включая проверку орфографии. При выборе инструмента Текст автоматически изменятся и атрибуты Панели управления.
Текст по контуру
Прямоугольный фрейм В любой программе вёрстки, в том числе в InDesign, действует блочная концепция размещения информации. Сначала создавался «контейнер», в терминологии программы Фрейм, потом в него помещалась какая-либо информация. Помимо текстового фрейма, существует графический фрейм, отличительным признаком которого являются две пересекающихся диагональных линии, указывающих на важный для макетирования центр фрейма. Графический фрейм легко преобразовывается в тестовый и наоборот, однако если внутри фрейма есть содержимое, то преобразование работать не будет. В Неопределенных фреймах есть черная рамка, в других нет[8]
Овальный фрейм
Многоугольный фрейм
Пипетка В работе со шрифтами Пипетка может выполнять функцию форматирования, для этого нужно выделить текст, выбрать его пипеткой и применить выбранное пипеткой форматирование к нужному тексту. Совмещена с инструментом Линейка.
Линейка
Рука Инструмент прокрутки. Для прокрутки в тексте лучше всего использовать клавишу Alt, она выбрана для этой цели, потому что не участвует в наборе вообще, а значит не может внести незапланированных изменений, в отличие от Пробела, навигацией которым рекомендуется пользоваться только при вёрстке изображений.
Масштаб Самым распространенным способом работы с масштабом, при одновременном использовании любого другого инструмента, является временный вызов лупы нажатием клавиш «Ctrl» + «Пробел», после того как все клавиши будут отпущены, в нашем распоряжении снова окажется активный инструмент[9], также можно масштабировать при помощи колесика мышки, предварительно нажав клавишу Alt на клавиатуре.

Панель управления[править | править вики-текст]

Панель управления активизируется с момента создания или открытия документа, до этого момента все основные ее функции неактивны, причем Панель атрибутов (контрольная панель) этой панели изменяется в зависимости от выбранного инструмента, к примеру, инструменту Текст назначается своя панель атрибутов, а Средства форматирования символов из подменю Текст будут иметь следующие особенности:

Инструмент Текст Кнопки Панели управления Краткое описание функций Панели управления при выбранном инструменте Текст
Средства форматирования символов Выбор шрифта Выбор шрифта (гарнитуры) из списка с просмотром его начертания, при этом следует отличать типы шрифтов, к примеру, шрифты TrueType и OpenType, в отличие от шрифтов PostScript, годны к использованию только на офисном печатном оборудовании. Для офсетной печати категорически не следует использовать системные шрифты типа Times New Roman. Большинство книг свёрстаны одним, реже двумя шрифтами PostScript.
Начертание Набор начертаний шрифта, в том числе есть Наклонное начертание и Курсив.
Надстрочный индекс Для обозначений спецсимволов вроде зарегистрированных торговых марок и подобных.
Кернинг В программе возможно избирательное изменение межсимвольных интервалов: кернинг обычно применяется к «неудачным» парам букв. В InDesign существует автокернинг, но его можно применить только к тем шрифтам, в гарнитуре которых есть встроенная таблица автокернинга. Таблица автокернинга для каждого шрифта разрабатывается художником-шрифтовиком, в ней указаны неудачные, с точки зрения типографики, сочетания символов, которые InDesign сдвигает в заданную разработчиком шрифта сторону. По умолчанию в InDesign используется Метрический кернинг, который зависит от гарнитуры (шрифта); при неудовлетворительном результате следует выбрать функцию Оптический кернинг либо отрегулировать кернинг вручную.
Трекинг В отличие от кернинга, трекинг — это равномерное изменение межсимвольных интервалов в выделенном тексте. В InDesign удобнее всего выделить текст, выбранный на вгонку и выгонку, используя сочетания клавиш Alt и стрелки, шаг трекинга регулируется через меню Трекинг. Обычно считается, что нельзя делать вгонку или выгонку более чем на 1 %, максимум 3 %[8].

Сравнение с другими программами вёрстки[править | править вики-текст]

InDesign — прямой конкурент QuarkXPress; конкурент от свободного ПО — кроссплатформенный Scribus. Начиная с версии CS5, наметилась тенденция к уменьшению количества пользователей QuarkXPress[8].

Особенности[править | править вики-текст]

  • Adobe InDesign имеет особенности, связанные с совместимостью файлов разных версий, к примеру, макет, свёрстанный в поздней версии программы, может не открыться в ранней и наоборот.
  • Запись из версии CS5 в формат более старых версий невозможна, в этом пакете есть совместимость только «снизу вверх»[9].
  • Если из CS5 и выше нужно пересохранить файл в версию CS3 и ниже, то это возможно при помощи InDesign CS4: нужно сохранить файл в idml, открыть его InDesign CS4 и пересохранить в inx.

InDesign Server[править | править вики-текст]

В октябре 2005 Adobe выпустила «InDesign Server CS2», изменённую версию InDesign (без пользовательского интерфейса) для Windows и серверных платформ Macintosh. InDesign Server создан для использования разработчиками в создании решений клиент-сервер с технологией программного расширения InDesign. В марте 2007 Adobe официально объявила Adobe InDesign CS3 Server как часть семейства Adobe InDesign.

Версии[править | править вики-текст]

Версия Дата выпуска Комментарии
1.0 16 августа 1999
1.5 Апрель 2001 * Лёд тронулся, или Приключения InDesign в России Статья из журнала для полиграфистов и издателей «КомпьюАрт» № 7’2001. С этой статьи началось шествие InDesign в России. В том же номере впервые в российской прессе появилась вёрстка реального материала в среде InDesign.
2.0 Январь 2002 Вышла через несколько дней после QuarkXPress 5. Поддержка Mac OS X, прозрачности и тени. Из недостатков наличие слабого интерфейса и отсутствие важных функций, появившихся в следующих версиях.
«CS»
«CS PageMaker Edition» (3.0)
Октябрь 2003 Так называемая региональная «североамериканская версия» имеющая базовые функции. Отсутствие поддержки русского языка исправлялось установкой русского словаря.
«CS2» (4.0) Май 2005 В состав программы включён русскоязычный словарь, обеспечивающий, в том числе правильные автоматические переносы.
Server Октябрь 2005
«CS3» (5.0) Апрель 2007 Поддержка регулярных выражений, таблиц стилей + новый интерфейс.
«CS3 Server» (5.0) Май 2007
«CS4» (6.0) Октябрь 2008 Множество нововведений и настройки по умолчанию, которые увеличивают скорость и качество вёрстки. По традиции предыдущих релизов улучшается сквозная интеграция с другими программами пакета Creative Suite. Переработан GUI, в котором теперь появились закладки, представляющие открытые файлы (аналогия — веб-браузеры с мультитабом).
«CS5» (7.0) 2010 Появились возможности веб-вёрстки, ранее для этих целей использовался Photoshop. В целом, это незначительно усовершенствованная «CS4» с интерфейсом «CS3».
«CS5.5» (7.5.3) 2011 Появление дополнительных функций не имеющих к процессу вёрстки прямого отношения.
«CS6» (22 апреля 2012) 2012
«CC» (22 июня 2013) 2013 Джейсон Левин, специалист по Adobe, так отозвался об этой версии: «[здесь] нет 50 новых функций, но зато программа полностью переписана под 64-битный код»[10].

См. также[править | править вики-текст]

Примечания[править | править вики-текст]

  1. [Программа] содержит инструменты для решения любых задач — от простейших бумажных проектов до сложных интерактивных электронных изданий, которые в последнее время все более и более востребованы.

    — А. Сераков, И. Агапова. InDesign CS6. Путь к мастерству, 2013, ISBN 978-5-699-57904-4

  2. В. Родионов. Подготовка электронных публикаций в InDesign CS6, 2013, ISBN 978-5-9775-0860-5.
  3. Adobe InDesign CS6. Официальный учебный курс, 2013, с. 17, ISBN 978-5-699-61164-5.
  4. Adobe InDesign CS6. Официальный учебный курс, с. 38.
  5. Adobe InDesign CS6. Официальный учебный курс, с. 25.
  6. Adobe InDesign CS6. Официальный учебный курс, с. 33.
  7. «Создание фолио»
  8. 1 2 3 Стеблянский Р. А.. Уроки Adobe InDesign. Верстка печатных и электронных изданий, Центр компьютерного обучения «Специалист» при МГТУ имени Н. Э. Баумана, 2011.
  9. 1 2 А. А. Ландер. Самоучитель Adobe InDesign CS5, ISBN 978-5-9775-0611-3.
  10. «Интервью с Джейсоном Левиным о новых продуктах Adobe Creative Cloud: Premiere Pro, After Effects» // iXBT.com от 17 июня 2013 года